Cannot get asctec_mav_framework working on atomboard/pelican

classic Classic list List threaded Threaded
2 messages Options
gdh
Reply | Threaded
Open this post in threaded view
|

Cannot get asctec_mav_framework working on atomboard/pelican

gdh
Hi,

I think I'm missing something obvious here --- help would be appreciated.

SETUP:
Pelican, atomboard (Ubuntu 12.04) with hydro (base version with necessary dependencies)
asctec_mav_framework compiles without errors, although gives me warnings that i'm mixing boost 1.46
LLP flashed to the 2012 version
HLP flashed with main.hex from asctec_hl_firmware
serial cable (the one with the loop in it) from ttyUSB0 to HLP

From an ssh into the atomboard, i run roslaunch asctec_hl_interface fcu.launch.  I get the following output:

asctec@asctec:~/catkin_ws/src/asctec_mav_framework$ roslaunch asctec_hl_interface fcu.launch
logging to /home/asctec/.ros/log/ca4b3cf2-d849-11dd-b392-000e8e313dd9/roslaunch-asctec-25604.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://asctec:55182/

SUMMARY
========

CLEAR PARAMETERS
 * /fcu/

PARAMETERS
 * /fcu/fcu/baudrate
 * /fcu/fcu/frame_id
 * /fcu/fcu/max_velocity_xy
 * /fcu/fcu/max_velocity_z
 * /fcu/fcu/packet_rate_ekf_state
 * /fcu/fcu/packet_rate_gps
 * /fcu/fcu/packet_rate_imu
 * /fcu/fcu/packet_rate_rc
 * /fcu/fcu/packet_rate_ssdk_debug
 * /fcu/fcu/position_control
 * /fcu/fcu/serial_port
 * /fcu/fcu/state_estimation
 * /fcu/ssdk/omega_0_xy
 * /fcu/ssdk/omega_0_z
 * /fcu/ssdk/p16
 * /fcu/ssdk/p17
 * /fcu/ssdk/p18
 * /fcu/ssdk/p20
 * /fcu/ssdk/p21
 * /fcu/ssdk/p22
 * /fcu/ssdk/p23
 * /fcu/ssdk/p24
 * /fcu/ssdk/p35
 * /fcu/ssdk/p36
 * /fcu/ssdk/p37
 * /fcu/ssdk/p38
 * /fcu/ssdk/p39
 * /fcu/ssdk/p40
 * /fcu/ssdk/p41
 * /fcu/ssdk/p42
 * /fcu/ssdk/p43
 * /fcu/ssdk/p45
 * /fcu/ssdk/p46
 * /fcu/ssdk/p48
 * /fcu/ssdk/p49
 * /fcu/ssdk/p9
 * /fcu/ssdk/tf_ref_frame_id
 * /fcu/ssdk/tf_tracked_frame_id
 * /fcu/ssdk/zeta_xy
 * /fcu/ssdk/zeta_z
 * /rosdistro
 * /rosversion

NODES
  /
    fcu (asctec_hl_interface/hl_node)

auto-starting new master
process[master]: started with pid [25618]
ROS_MASTER_URI=http://asctec:11311

setting /run_id to ca4b3cf2-d849-11dd-b392-000e8e313dd9
process[rosout-1]: started with pid [25631]
started core service [/rosout]
process[fcu-2]: started with pid [25644]


From a "cat /dev/ttyUSB0" I can see some symbols being transmitted over the cable.  I can attach these later if needed.

I then run rosnode list, which returns

/rosout

rostopic list gives me:

/rosout
/rosout_agg

Sometimes I get an fcu node but I cannot ping it (despite it reportedly existing).  

I'm not sure how to go about debugging this.

Cheers,

Gerard







gdh
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get asctec_mav_framework working on atomboard/pelican

gdh
Some more info:

I get a library clash -- some of my code needs boost 1.54 and asctec_mav_framework under ubuntu 12.04 uses 1.46 I think.  Gcc spat out some warnings so I'm going to try to recompile the asctec code with boost 1.46.

Another thing --- I flash the HL processor with main.bin (or main.hex --- tried both) but take no further steps.  Should I compile anything on the HLP or is that only if I want to write code on the HLP instead of using the atomboard?

Regards,

Gerard