GPS doesn't lock

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

GPS doesn't lock

Carms
Hello everyone.
I am working with a Firefly; at the moment I was able to make it fly indoor controlling the position by means of the on-board camera and a wall of markers.

Now I was planning to use it outdoor using the position measured with the gps receiver. The problem is that the GPS signal does not seem to lock (the red led 4 keeps flashing, while the green led 3 flashes at 2.5 hz). I tried more than once, with the Firefly outside and waiting more than 10 minutes. I tried also to move the GPS switch and the serial switch on the Futaba controller, but without any results.

Reading the gps variables from the serial interface, I checked that it doesn't find any satellite (GPS_sat_num is always 0).

Do you think that it could be a problem related to the antenna, or to the GPS hardware? Or is there something wrong in my procedure?

Thank you very much,
Carmine