SDK 3.0 does not work with Simulink

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SDK 3.0 does not work with Simulink

Zdenek Boucek
This post was updated on .
I tried to use Hummingbird with Simulink using AutoPilot_HL-Simulink_SDK_v2.0. UART_communication reads data through Xbee and onboard_matlab attitude controller works too. If I try same thing with SDK 3.0, project is built (even it defines parameter MATLAB=1), Hummingbird's Autopilot is flashed, but it does not execute code, which is defined for Matlab (com for Matlab/Simulink and controller from onboard_matlab does not work). I tried new Eclipse supplemented with Zylin, but it behaved the same. I use Matlab R2014b and Windows 7.

Edit: output of Eclipse Mars after compilation of project

16:40:18 **** Incremental Build of configuration AscTec Simulink Toolkit for project AscTec_SDK_v3.0 ****
make MATLAB=1 all

-------- begin (mode: ROM_RUN) --------
Building Simuling Toolkit Configuration...
arm-elf-gcc (GCC) 4.1.1 (WinARM)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Size before:
main.elf  :
section             size         addr
.text             121480            0
.data               3496   1073741824
.bss               20172   1073745320
.stack              6528   1073765632
.comment            1998            0
.debug_aranges      1264            0
.debug_pubnames     7996            0
.debug_info        54025            0
.debug_abbrev       6952            0
.debug_line        11517            0
.debug_frame        5476            0
.debug_str          7265            0
.debug_loc         13796            0
.debug_ranges        856            0
Total             262821




Size after:
main.elf  :
section             size         addr
.text             121480            0
.data               3496   1073741824
.bss               20172   1073745320
.stack              6528   1073765632
.comment            1998            0
.debug_aranges      1264            0
.debug_pubnames     7996            0
.debug_info        54025            0
.debug_abbrev       6952            0
.debug_line        11517            0
.debug_frame        5476            0
.debug_str          7265            0
.debug_loc         13796            0
.debug_ranges        856            0
Total             262821



Errors: none
-------- end --------


16:40:18 Build Finished (took 339ms)

Edit: Problem solved! Project must be cleaned after setting the build for MATLAB.
Loading...