Simulink not receiving data from Pelican.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Simulink not receiving data from Pelican.

Callum Walley
Hey there,
I have been using the simulation toolkit with the AscTec pelican for about 3 months now, and everything has (more or less) worked, but suddenly out of the blue I am no longer receiving/sending data with the voltage and CPU indicators reading 0, also my control channels don't work.

I have tested
*AciTool on the HL port receives data no problem.
*AutoPilot on the LL port works no problem.
*I have re-flashed the drone with SDK 3.0 and 2.0 multiple times. (It acknowledges the flash with 2/3 beeps)
*Started with a clean unmodified version of the Simulink files
*Tried all of the above on 2 other computers.

I can't figure out what the problem could be.

I am presenting the entire project next week so this is the worst possible time to happen, any advice is appreciated I am getting desperate.