Unable to start JTAG connection

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to start JTAG connection

Mauro Franceschelli
Dear all,

    we are unable to to start the JTAG connection with the hummingbrid. By following all instructions given in the manual, when we initiate the command: "Run>External Tools>OpenOCD Asctec-JTAG", in the console appears the following string:

Info:    openocd.c:92 main(): Open On-Chip Debugger (2007-08-10 22:30 CEST)

After 30 seconds it appears the following error message:

Error:   ft2232.c:236 ft2232_read(): couldn't read the requested number of bytes from FT2232 device (0 < 81)
Error:   ft2232.c:376 ft2232_send_and_recv(): couldn't read from FT2232

If we try the command  "Run>Debug Configuration>AscTec JTAG Debug"

we get this:

target remote localhost:3333
localhost:3333: Unable to establish connection. Persistent refusal of the target computer.
monitor sleep 500
"monitor" command not supported by this target.
monitor poll
"monitor" command not supported by this target.
monitor flash probe 0
"monitor" command not supported by this target.
monitor flash erase 0 0 13
"monitor" command not supported by this target.
monitor flash write 0 main.bin 0x0
"monitor" command not supported by this target.
monitor reset run
"monitor" command not supported by this target.
monitor sleep 500
"monitor" command not supported by this target.
monitor soft_reset_halt
"monitor" command not supported by this target.
monitor arm7_9 force_hw_bkpts enable
"monitor" command not supported by this target.
symbol-file main.elf
thbreak main
No hardware breakpoint support in the target.
continue
The program is not being run.
No registers.

Could anybody help with this? any help is appreciated.

The PC has windows XP, the ACI remote communication tool seems to work fine so I guess it is not a problem with the quadrotor.

Best regards

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to start JTAG connection

Mauro Franceschelli
It was apperently a windows XP issue. We solved by switching to windows 7.
Loading...