cannot locate [autopilot.launch] in package [asctec_autopilot] ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

cannot locate [autopilot.launch] in package [asctec_autopilot] ?

Paul Ozog
I figure it would help me debug our LCM stack on the Pelican if I were to run ROS.

How come autopilot.launch isn't in asctec_autopilot?  Is the wiki out of date?
$ roslaunch asctec_autopilot autopilot.launch
cannot locate [autopilot.launch] in package [asctec_autopilot]

Can I still run the asctec_mon and collect data without autopilot.launch running?
Reply | Threaded
Open this post in threaded view
|

Re: cannot locate [autopilot.launch] in package [asctec_autopilot] ?

Bill Morris
Administrator
On Sun, 2011-04-03 at 10:40 -0700, Paul Ozog [via asctec-users] wrote:

> I figure it would help me debug our LCM stack on the Pelican if I were
> to run ROS.
>
> How come autopilot.launch isn't in asctec_autopilot?  Is the wiki out
> of date?
> $ roslaunch asctec_autopilot autopilot.launch
> cannot locate [autopilot.launch] in package [asctec_autopilot]
>
> Can I still run the asctec_mon and collect data without
> autopilot.launch running?
>
>
> ______________________________________________________________________
> If you reply to this email, your message will be added to the
> discussion below:
> http://asctec-users.986163.n3.nabble.com/cannot-locate-autopilot-launch-in-package-asctec-autopilot-tp2771894p2771894.html 
> To start a new topic under asctec-users, email ml-node
> +[hidden email]
> To unsubscribe from asctec-users, click here.

I'm not sure why but all of the launch files were moved to the
ccny_experimental stack. In either the city_flyer_launch or
pelican_launch packages.

I'll look into this tomorrow and either get them moved back or the docs
updated.

Reply | Threaded
Open this post in threaded view
|

Re: cannot locate [autopilot.launch] in package [asctec_autopilot] ?

IvanDryanovski
Administrator
In reply to this post by Paul Ozog
Hi Paul,

Most likely I added it to the wiki but forgot to check it in git. I
will resolve it by tomorrow and let you know.

Ivan

On Sun, Apr 3, 2011 at 1:40 PM, Paul Ozog [via asctec-users]
<[hidden email]> wrote:

> I figure it would help me debug our LCM stack on the Pelican if I were to
> run ROS.
>
> How come autopilot.launch isn't in asctec_autopilot?  Is the wiki out of
> date?
> $ roslaunch asctec_autopilot autopilot.launch
> cannot locate [autopilot.launch] in package [asctec_autopilot]
>
> Can I still run the asctec_mon and collect data without autopilot.launch
> running?
>
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://asctec-users.986163.n3.nabble.com/cannot-locate-autopilot-launch-in-package-asctec-autopilot-tp2771894p2771894.html
> To start a new topic under asctec-users, email
> [hidden email]
> To unsubscribe from asctec-users, click here.
Reply | Threaded
Open this post in threaded view
|

Re: cannot locate [autopilot.launch] in package [asctec_autopilot] ?

IvanDryanovski
Administrator
In reply to this post by Paul Ozog
Paul,

We added the launch file to the asctec_proc package in 1.0.1 of
asctec_drivers, but we haven't pushed out that debian yet. I am
attaching the launch file. I would recommend that you install version
1.0.0 of asctec_drivers, if you havent done so already:

http://www.ros.org/wiki/asctec_drivers

If you want more info on asctec_proc, you can check out this page:

http://www.ros.org/wiki/asctec_proc

As for asctec_mon, I'm not sure if that has been updated to work with
the new asctec_proc driver. If it doesn't work, you can use `rostopic
echo` on any of the topics described in the wiki page for asctec_proc.

I hope this helps - let me know if you have more questions.

Cheers,
Ivan

On Sun, Apr 3, 2011 at 2:19 PM, Ivan Dryanovski
<[hidden email]> wrote:

> Hi Paul,
>
> Most likely I added it to the wiki but forgot to check it in git. I
> will resolve it by tomorrow and let you know.
>
> Ivan
>
> On Sun, Apr 3, 2011 at 1:40 PM, Paul Ozog [via asctec-users]
> <[hidden email]> wrote:
>> I figure it would help me debug our LCM stack on the Pelican if I were to
>> run ROS.
>>
>> How come autopilot.launch isn't in asctec_autopilot?  Is the wiki out of
>> date?
>> $ roslaunch asctec_autopilot autopilot.launch
>> cannot locate [autopilot.launch] in package [asctec_autopilot]
>>
>> Can I still run the asctec_mon and collect data without autopilot.launch
>> running?
>>
>> ________________________________
>> If you reply to this email, your message will be added to the discussion
>> below:
>> http://asctec-users.986163.n3.nabble.com/cannot-locate-autopilot-launch-in-package-asctec-autopilot-tp2771894p2771894.html
>> To start a new topic under asctec-users, email
>> [hidden email]
>> To unsubscribe from asctec-users, click here.
>

asctec_driver.launch (1K) Download Attachment